GCC 4.3… it will be a bloodshed

Martin Michlmayr is writing on Planet Debian a series of blog entries about the upcoming compile errors of GCC 4.3, with old warnings promoted to errors, and stricter compiler in general.

It’s interesting to read his entry about pedantic warnings turned errors. Now I’m all for stricter compilers, because it means improved code, but this is going to give a lot of Gentoo developers headaches and heartaches.. and to the GCC porting it might as well become stomachache.

Hopefully, it will take a bit of time before GCC 4.3 is ready for public consumption, but… well, if you see something issuing such warnings, it might be worth telling that upstream to remove them to begin with…

One thought on “GCC 4.3… it will be a bloodshed

  1. GCC! Improving a strict and sane opensource diet by source incompatibility AND binary incompatibility ;)

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s