Tomcat 5.5 on Gentoo/FreeBSD

So tonight I was finally able to get Tomcat 5.5 to work on Gentoo/FreeBSD! YEEE! Netbeans is still far as there’s a package that still depends on mx4j (that in turn still end up asking for a 1.4 series JDK that we don’t have), but at least half the dependencies (Tomcat) is done:

Screenshot of Konqueror showing Tomcat's status

It’s still not keyworded in tree because there are some bugs that has to be fixed before that can be done, but thanks to the Gentoo/Java team (Betelgeuse, Cater, nichoj and wltjr in alphabetical order), most of the trouble is now fixed, I didn’t even have to report any package not migrated to generation 1 (but I was using the migration overlay, I didn’t check how much of them were taken from there).

Next step is getting Firebird building and installing, waiting for Netbeans.