My birthday is coming

No, I’m not saying that because I want gifts (although, if you really want, my wishlist has a few items on it — just joking, don’t take me seriously), but to update the situation about my personal birthday present, XMMS removal, that is.

Today we’re about at the middle of the month while XMMS is masked, and thus I decided to proceed with a second phase of the removal: the removal of useflags. I’ve removed all the xmms useflags from the packages, and the infopipe useflag from conky, so that no package should anymore depend on xmms directly, a part the masked ones. If you want to maintain an XMMS overlay, add the support for XMMS plugins like faad2 as a different ebuild, or we’ll start marking INVALID all the bugs reported by users with an xmms overlay in it.

For the people complaining about Amarok unable to play their ID3-tagged FLAC files, or OggFlac files, I’ve also put a new snapshot yesterday (let’s call it “Angel Release”, just because yesterday was the birthday of a friend of mine) that will solve those problems. It’s still masked, but as soon as Luca unleashes the latest FFmpeg, xine-lib-1.1.3_pre20061112 will follow.

Also, I wish to thank Alessio (X-Drum) who’s taking a look at sound bugs for the proaudio software.. I’ll be committing a few things today or tomorrow :)

Okay, now I might go look for something to eat, as I woke up late, and I haven’t had lunch yet.

12 thoughts on “My birthday is coming

  1. Hi, Diego.Sorry for sending you “Help me with Amarok” emails, but I’ve found nobody with the same insight in that particular program anywhere else. I found that bugzilla posting about Amarok simply crashing on start and sadly that seems to be my problem too. It does try to connect to the mysql db, but fails. But I see no errors anywhere and the login works (tried it with phpmyadmin). I tried all the suggested settings on the Howto Amarok+mysql, but to no avail. After all your rants about it I really wanted to try it, but seems I will have to skip it and stick to Audacious instead. Which works like a charm, btw.I opted for installing xmms and all its plugins while it was still available and just leave it there. Eventually all other tools that use those plugins will have changed their code, but to avoid unnecessary broken progs I figured I’d do that for now. I don’t use it for playing music.If you do have any clues on making Amarok not crash I think there’d be plenty users that’d be happy.

    Like

  2. Sorry Kim if I didn’t answer, but it followed the fate of most of the mails I received in the last month (moved to the TODO folder). I’ll try to answer those asap.

    Like

  3. Thank you.No real need to answer me personally. Check bugzilla, they are having the same problem as I have and if my memory serves me right I added a blurb there too.Right now my system is running an update to KDE 3.5.5. I wonder if that’s a smart move or not :-/ Not all ~x86 flags are good for one’s well being :-)

    Like

  4. Hi Diego,I am sorry to have to involve you as you already have a lot on your plate.But I was told by some people from amarokthat I should talk to you about this.This is another xine-lib/amarok problem.Since the xmms removal I didn’t have a player capable of playing shn (shorten) files, but support for it appeared in ffmpeg so I decided to give it a spin (I am on gentoo on ppc by the way).ffplay plays shn, xine (xine-lib-1.1.2-r2) plays shn but not amarok (1.4.3 and 1.4.4) with xine engine! I filled a bug/wish (#137227) in amarok asking for shn support and someone started to say “It is because of lack of support in taglib ask there”. Turns out shn is tagless so it is not an issue. Finally I was told without any real explanation that the problem was lying with xine and if I wanted to know why I should ask you as you are a xine dev (this I was told in a private message not on bugzilla).

    Like

  5. Francois, the problem with shorten I fixed already in xine-lib (I was reported so on #amarok some time ago), and it’s already in the current ~arch xine-lib (1.1.3 snapshot unmasked today).So just update to that version, and Amarok will play them just fine :) (although it won’t be able to read tags from them at the moment, I’m afraid… that can be fixed easily if you ask Amarok people).

    Like

  6. Thanks for the speedy answer Diego!As far as I know shn is tagless so there is nothing to worry about that unless someone decide to extend the format.I got a bit upset at amarok people because they were giving me answers that, as a university lecturer, I consider no answer at all (I will give bad marks to a student that gives me the kind of answers they gave me). If someone had told me “we know of this and it has already been tracked down” I would have shut up.Now to compiling xine-lib :)

    Like

  7. Hello Diago,you should block the as-needed flag in the ffmpeg build as it bails out while trying to find lame.

    Like

  8. Kim, I tried to reach Ian Monroe so he can take a look again, I’m not a big mysql expert or user, and that sounds like an upstream issue.Florian, the lame problem is actually fixed already, just re-emerge lame and then ffmpeg will build again (by the way, –as-needed is added by upstream, so it should remain there).

    Like

  9. On the mysql problem, I’m getting the same response when trying to have webmin read a table inside a database. I can read the different databases, but I can’t click on them. I get the known error: DBI connect failed : Can’t connect to local MySQL server through socket ”/var/run/mysqld/mysqld.sock” (2)I have the following versions of what I think are relevant programs:dev-perl/DBD-mysql 2.9007dev-perl/DBI 1.50dev-perl/Apache-DBI 0.94net-www/apache 2.0.59-r2dev-db/mysql 5.0.26-r1In some places it is suggested to comment out “bind-address 127.0.0.1”, which I tried, but to no avail, still no go.

    Like

  10. Failed to read a valid object file image from memory.I see that error everytime I run amarok/app.

    Like

  11. If you get an error like this:Can’t connect to local MySQL server through socket ’’/var/run/mysqld/mysqld.sock’’ (2)Try starting amarok, going to settings -> config amarok… -> collectionsIn the field hostname, put this:127.0.0.1

    Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s